2017

Bom 2017 a todos

19 de jun de 2011

FMSLogo

O comando ativetemporizador é um recurso no SuperLogo que permite executar tarefas em paralelo. Segue exemplo usando placa Gogo.

ativetemporizador 1 5000 [mostre sensor1]
;nota o SuperLogo voltou e o temporizador está executando (alterando o lápis randomicamente)
repita 72 [repita 4 [pf 100 pd 90] pd 5]
desativetemporizador 1

ativetemporizador 2 1000 [se sensor2 > 50 [atA ligapor 10]
pf 2 pd sorteienúmero 5
desativetemporizador 2
Compare agora as ideias abaixo (uma de cada vez):
ativetemporizador 2 100 [pf 2 pd sorteienúmero 5]
desativetemporizador 2
ativetemporizador 2 100 [pf 2 pd sorteienúmero 5]
desativetemporizador 2

É bom sempre ler o manual de ajuda que vem com o programa (tecla F1).
A mesma recomendação faço para quem usa o FMSLogo!
No FMSLogo, poderíamos testar o seguinte (nota: em vez de ativetemporizador, usamos mudetemporizador ou mudecontador).
mudetemporizador 1 5000 [mostre sensor1]
;a sequência acima lerá o valor do sensor1 a cada 5 segundos (5000 milissegundos)
repita 72 [repita 4 [pf 100 pd 90] pd 5]
;depois de encerrada a atividade, desative o temporizador com o comando abaixo
desativetemporizador 1

mudetemporizador 2 1000 [se sensor2 > 50 [atA ligapor 10]
pf 2 pd sorteie 5
desativetemporizador 2
Compare agora as ideias abaixo (uma de cada vez):
mudetemporizador 2 100 [pf 2 pd sorteie 5]
desativetemporizador 2
mudetemporizador 2 100 [pf 2 pd sorteie 5]
desativetemporizador 2

Alguma dúvida ou sugestão? Deseja saber como fazer uma tarefa X?
Deixe seu comentário.

Nenhum comentário:

Em destaque

Verbos

Atividade desenvolvida para planilha eletrônica pelo multiplicador Ademir dos Santos há alguns anos, resolvi colocar online usando recursos ...